419
submitted 11 months ago* (last edited 11 months ago) by varsock to c/meta

Drawing attention on this instance so Admins are aware and can address the propagating exploit.

EDIT: Found more info about the patch.

A more thorough recap of the issue.

GitHub PR fixing the bug: https://github.com/LemmyNet/lemmy-ui/pull/1897/files

If your instance has custom emojis defined, this is exploitable everywhere Markdown is available. It is NOT restricted to admins, but can be used to steal an admin's JWT, which then lets the attacker get into that admin's account which can then spread the exploit further by putting it somewhere where it's rendered on every single page and then deface the site.

If your instance doesn't have any custom emojis, you are safe, the exploit requires custom emojis to trigger the bad code branch.

you are viewing a single comment's thread
view the rest of the comments
[-] askat 17 points 11 months ago
[-] [email protected] 11 points 11 months ago

Paid someone to do it, that man can't code.

this post was submitted on 10 Jul 2023
419 points (98.6% liked)

Programming.dev Meta

2375 readers
32 users here now

Welcome to the Programming.dev meta community!

This is a community for discussing things about programming.dev itself.

Links

Credits

founded 1 year ago
MODERATORS