The spec requires errors to be a single string, and also mandates using the space character as a separator? I'm not a fan of deviating from spec, but those are...bad choices in the spec.
BatmanAoD
Tortoise git is probably what convinced me to just use the CLI for everything back in the day. Tortoise SVN is basically 1:1 with the SVN CLI (as far as I could tell, at least); Tortoise Git was...not.
Maybe other git UIs are better. I hope so! Maybe even Tortoise has gotten better. But it was not good back then. (This was around 2013.)
For anyone else wondering, here's the text of the actual email cited as the CoC violation:
Michal, if you think crashing processes is an acceptable alternative to error handling you have no business writing kernel code.
You have been stridently arguing for one bad idea after another, and it's an insult to those of us who do give a shit about writing reliable software.
You're arguing against basic precepts of kernel programming.
Get your head examined. And get the fuck out of here with this shit.
I agree, but if you look at the specific email linked, it very clearly crosses the line into direct abuse, whereas most of Linus's rants do exist in a slightly greyer area (even if they'd be grounds for a discussion with HR at an actual company).
the function reads the comment added after the function is called using a backtrace and uses them as arguments
How marvelously creative. What an abomination.
(I haven't checked what the warning says today.)
Well, yeah, that's why the linked ticket led to a massive improvement:
If you don't know what git is, you should probably avoid choosing the "confirm" option when you're warned that an operation is dangerous.
That said, I think the change they ultimately made in the linked issue, which words the warning differently and, more importantly, provides an option to only discard changes to already-tracked files, is a vast improvement.
That depends on what you map "discard" to in your mental model. Whoever designed the VSCode feature chose to associate it with reset+clean, rather than just reset. Presumably that's why they called the menu option "discard" rather than "reset". (But I agree that this is a surprising choice, and that they managed to make an already-famously-bad UX even worse.)
Well, yeah, that's why they updated the warning pop-up. It's still the case that the user didn't bother to find out what the warning meant before choosing the inherently destructive option.
Here's the revised pop-up, according to the linked ticket:
I haven't checked the current behavior (this whole incident was seven years ago).
I meant it in a completely light-hearted way, but I do wonder if some of the downvoters don't realize I'm talking about the username.
Yeah, consistency is good, which is why it's good to follow the spec. I'm saying that the decision to make errors be flat strings in the spec was a bad one. A better design would be what you have, where
code
is nested one level belowerror
, plus permitting extra implementation-defined fields in that object.